Funciones "Y" y "O" | Microsoft Excel 2013

La función Y es una función lógica que nos permitirá evaluar varias expresiones lógicas y saber si todas ellas son verdaderas y la función O como cualquier expresión lógica devuelve los valores Verdadero o Falso después de evaluar las expresiones.


Publicado: Editado: Estado:

Función Y

La función Y en Excel es una función lógica que nos permitirá evaluar varias expresiones lógicas y saber si todas ellas son verdaderas. Será suficiente con que cualquiera de las expresiones sea falsa para que el resultado de la función también sea FALSO.

Ejemplo 1

Según los datos edad y nacionalidad determine con la función Y si cumple con los requisitos. Serán verdaderos los mayores e iguales de 18 y que sean de Nicaragua.

Pasos:

  1. Ir a la pestaña formulas
  2. Luego de clic en botón insertar función
  3. Busque la función Y  

excel-2013

excel-2013

Solución:

=Y(A2>=18,B2="Nicaragua")​

Utilizando la función Y podemos evaluar condiciones múltiples en Excel que deben cumplirse obligatoriamente.  Es decir, solamente para aquellos casos donde cada condición sea verdadera la función Y regresará un valor verdadero. Bastará que solo un valor sea falso para que todo el resultado sea falso. Observa la siguiente función.​

Ejemplo 2

Determinar que alumno completó las tres actividades. ¿Aprobó? El resultado será un Verdadero o Falso

excel-2013


excel-2013

Solución:

=Y(B2,C2,D2)

 

Función O

 

La función O es una de las funciones lógicas de Excel y como cualquier otra función lógica solamente devuelve los valores VERDADERO o FALSO después de haber evaluado las expresiones lógicas que se hayan colocado como argumentos.

  • Valor_lógico1 (obligatorio): Expresión lógica que será evaluada por la función.
  • Valor_lógico2 (opcional): A partir del segundo argumento las expresiones lógicas a evaluar con opcionales hasta un máximo de 255.

excel-2013

La única manera en que la función O devuelva el valor FALSO es que todas las expresiones lógicas sean falsas.

Ejemplo 1

En el siguiente ejemplo utilizo las funciones ESNUMERO y ESTEXTO para evaluar el tipo de dato de las celdas. 

excel-2013

Solución:

=O(ESNUMERO(A2),ESTEXTO(B2))

 

Ejemplo 2

En este ejercicio se tienen 3 operaciones de suma y con ayuda de la función SI se determinará si al menos una de la respuesta es verdadera.

excel-2013

excel-2013

 

Solución:

=SI(O(1+1=1,2+2=5,5+5=10), "respuesta si es verdadero", "respuesta si es falso")

 

Ejemplo 3

Una empresa quiere promover a una nueva sección al empleado que cumplan con las siguientes condiciones: 

  • Pertenecer al turno mañana.
  • Ser de la categoría 1 o que su sueldo sea menor o igual a 7.000$.

Para esto cuenta con la siguiente tabla que debe ser completada; donde los turnos son M,T ,N ,correspondientes a mañana, tarde y noche respectivamente y las secciones van de 1 a 4.

excel-2013

excel-2013

Solución:

=SI(Y(O(E2=4,D2<=7000),Y(C2="M")),"PROMUEVE","NO PROMUEVE")


Para descargar el ejercicio realizado con Microsoft Excel 2013 de clic aquí

Bibliografía
Dar puntos de agradecimiento
Reportar esta publicación

Déjanos tu comentario

Comentarios

mariogarcia

(Administrador)

Intereses

música, diseño, programación, electrónica, historia, geografía

Puntos: 146 Votos: 113