Función "SI" | Microsoft Excel 2013

La función SI nos permite evaluar una condición y ejecutar una acción dependiendo el resultado, ya sea verdadero o falso.


Publicado: Editado: Estado:

Función SI

La función SI nos permite evaluar una condición y ejecutar una acción dependiendo el resultado, ya sea verdadero o falso.

Ejemplo 1:

Supongamos que tenemos una partida de plátanos, de manera que si no miden igual o más que 15 cm de longitud no los podemos vender en el mercado. Catalogaremos como “Apto” el plátano que podemos vender (mide igual o más de 15 cm) y como “No apto” el pequeño.

Pasos:

  1. Ir a pestaña Fórmulas
  2. Dar clic en Insertar función

 

  1. Aparecerá una ventana
  2. Selecciona la función SI (Sino aparece la función, selecciona en categoría Todo para mostrar todas las funciones disponible)

  1. Una vez hallas seleccionado la función da clic en aceptar
  2. Aparecerá otra ventana que te pedirá
    1. Prueba lógica donde irá la condición
    2. Valor si verdadero si la condición se cumple
    3. Valor si falso si de lo contrario la condición no se cumple

  1. Donde la Prueba lógica será B2 >= 15 y si es verdadero dirá “Apto” de lo contrario “No apto”
  2. Una vez tengas esto das clic en aceptar

Solución:

=SI(B3>=15,"Apto","No apto")

NOTA IMPORTANTE: En algunos casos se utiliza el punto y coma (;) y en otros la simple coma (,), y resulta que nuestro Excel no lo reconoce generando un error. Esto sucede por la configuración regional de idioma.

=SI(A1>0;A1*B1;A1*C1)

=SI(A1>0,A1*B1,A1*C1)

Veamos el siguiente ejemplo, esta vez utilizando la función SUMA dentro de la función SI.

Ejemplo 2:

Digamos que tu presupuesto para un año es de $ 6000 e introduces tus gastos por meses. Deseas saber si has excedido tu presupuesto en un año dado. Para hacer esto, puedes usar la función SUMA dentro de la función SI.

Pasos:

  1. Siguiendo los pasos del ejemplo 1 hasta poder abrir la ventana de la función SI
  2. Agregamos

  1. La tabla quedará así

Solución:

=SI(SUMA(B2:B13)>6000,"Presupuesto Excedido","Presupuesto Ok")

Función SI anidada

Para utilizar correctamente la función SI anidada debemos utilizar una función SI como el tercer argumento de la función principal.

Ejemplo 3:

Evaluar a estudiante según la calificación obtenida, tenga en cuenta que la nota válida es de 0 a 100, si se ingresa una calificación de -1 o 101 que muestre un mensaje “No válido”

Pasos:

  1. Para este ejemplo escribiremos la formula directamente en la celda.
  2. Utilizaremos la función Y que nos ayuda a poder comparar la calificación con un determinado intervalo.
  3. La función Y tiene dos condiciones que obligatoriamente ambas tiene que ser verdadera para dar como resultado verdadero de lo contrario si una de ellas es falsa dará un resultado falso.

Solución:

=SI(Y(A2>=90,A2<=100),"Excelente",SI(Y(A2>=80,A2<=89),"Muy Bueno",SI(Y(A2>=70,A2<=79),"Bueno",SI(Y(A2>=60,A2<=69),"Regular",SI(Y(A2>=0,A2<=59),"Deficiente","No válido")))))

 

Bibliografía

Para descargar el ejercicio realizado con Microsoft Excel 2013 de clic aquí

Dar puntos de agradecimiento
Reportar esta publicación

Déjanos tu comentario

Comentarios

mariogarcia

(Administrador)

Intereses

música, diseño, programación, electrónica, historia, geografía

Puntos: 146 Votos: 113